$re = '/(?<name>\D*?) (?<grade>(A)?(B)?(C)?(D)?(E)?(FX)?(F)?)(?<ex>(-+)|(\++))?/m';
$str = 'abelone A--------
andersine A+
bo A
bosse A++
anton FX-
antonina FX+
anders A+
konstantin FX
william F
andreas A+
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);