const regex = /(<\sREP\s1\s\S+\s.+\s>)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<\\sREP\\s1\\s\\S+\\s.+\\s>)', '')
const str = `< REP 1 CHAN_NAME {yyyyyyyy} >
< REP 1 AUDIO_GAIN 042>
< REP 1 GROUP_CHAN gg, cc >
< REP 1 FREQUENCY yyyyyy >
< REP 1 ENCRYPTION yy >`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}