$re = '/(\d{1,4}?[-.\s]?)*/';
$str = '01.01 0-205060604-505202
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);