re = /^([\w-\.]+@(?!gmail.com)(?!yahoo.com)(?!hotmail.com)([\w- ]+\.)+[\w-]{2,4})?$/
str = 'username@domainname.net'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end