package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[0-31][0-24][0-60].Z`)
var str = `101010Z`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}