$re = '/^0\d(?:[ .-]?\d{2}){4}$/';
$str = '0145391617';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);