package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[ ^][A-F0-9][ $]`)
var str = `A A A A A A`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}