#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<!\\)(?:\[{2}[^\n|]+(?:\|[^\n]+)?]]|\[[^\n]+]\([^\n:]+\))"
Local $sString = "[[Link name|title]]" & @CRLF & _
"" & @CRLF & _
"[[Link name]]" & @CRLF & _
"" & @CRLF & _
"[[do not" & @CRLF & _
"|match]]" & @CRLF & _
"[I am not a link]]" & @CRLF & _
"some (text) [[Link]] more [text]" & @CRLF & _
"" & @CRLF & _
"\[[This is not a link]]\[[[this is|a link]] foo bar ]" & @CRLF & _
"" & @CRLF & _
"[[Folder Name/Link|link]]" & @CRLF & _
"" & @CRLF & _
"[[Folder/other folder/file|label]]" & @CRLF & _
"" & @CRLF & _
"[[]]" & @CRLF & _
"[[A [link] with brackets]]" & @CRLF & _
"" & @CRLF & _
"[[A [link] with brackets|on [both] sides]]" & @CRLF & _
"" & @CRLF & _
"[[A [bracket] folder/A [link] with brackets|on [both] sides]]" & @CRLF & _
"" & @CRLF & _
"Markdown: [Three laws of motion](Three%20laws%20of%20motion.md)" & @CRLF & _
"" & @CRLF & _
"\[Not a link](Three%20laws%20of%20motion.md)" & @CRLF & _
"" & @CRLF & _
"[also" & @CRLF & _
"not](a link)" & @CRLF & _
"" & @CRLF & _
"[This [is] a link](Three%20laws%20of%20motion.md)" & @CRLF & _
"" & @CRLF & _
"[Yes, you can put (parens) and [brackets] in a filename](Yes,%20you%20can%20put%20(parens)%20and%20[brackets]%20in%20a%20filename)" & @CRLF & _
"" & @CRLF & _
"[This is an external link](https://regex101.com)" & @CRLF & _
"" & @CRLF & _
" [[#Preview a linked file]] is a link to a heading in the current document." & @CRLF & _
"" & @CRLF & _
" [[Obsidian#Links are first-class citizens]] is a link to a heading in another document." & @CRLF & _
"" & @CRLF & _
"[[Help and support#Questions and advice#Report bugs and request features]] is a link to a subheading in another document." & @CRLF & _
"" & @CRLF & _
"You can link to a block by adding #^ at the end of your link destination followed by a unique block identifier. For example, [[2023-01-01#^37066d]]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")