re = /(^(?<barCodeId>\d{2})(?<serviceType>\d{3})(?<mailerId>\d{6})(?<uniqueSequence>\d{9})(?<dpbc>.{11}))/m
str = '0014120556239013447647712510026
0014120556239013447747712556417
0014120556239013447847712504124
0014120556239013447947712500422
0014120556239013448047712482006
0014120556239013448147712494417
0014120556239013448247712935544
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end