package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*\d{5}\s*$`)
var str = `29090900`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}