$re = '/(?<=TELEPHONE:)[0-9]+/';
$str = '<p>TELEPHONE:2131312321</p>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);