re = /(?=^.{7,}$)(?=.*\d)(?=.*[A-Za-z])(?=.*[@'#.$;%^&+=!""()*,-\/:<>?]).*$/
str = 'q2@\'#.$;%^&+=!""()*,-/\\\\\\\\\\///:<>?'
# Print the match result
str.match(re) do |match|
puts match.to_s
end