#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\+)[0-9\-]*"
Local $sString = "/+1-541-754-3010 156 Alphand_St. <J Steeve>" & @CRLF & _
" 133, Green, Rd. <E Kustur> NY-56423 ;+1-541-914-3010" & @CRLF & _
"+1-541-984-3012 <P Reed> /PO Box 530; Pollocksville, NC-28573" & @CRLF & _
" :+1-321-512-2222 <Paul Dive> Sequoia Alley PQ-67209" & @CRLF & _
"+1-741-984-3090 <Peter Reedgrave> _Chicago" & @CRLF & _
" :+1-921-333-2222 <Anna Stevens> Haramburu_Street AA-67209" & @CRLF & _
"+1-111-544-8973 <Peter Pan> LA" & @CRLF & _
" +1-921-512-2222 <Wilfrid Stevens> Wild Street AA-67209" & @CRLF & _
"<Peter Gone> LA ?+1-121-544-8974 " & @CRLF & _
" <R Steell> Quora Street AB-47209 +1-481-512-2222" & @CRLF & _
"<Arthur Clarke> San Antonio $+1-121-504-8974 TT-45120" & @CRLF & _
" <Ray Chandler> Teliman Pk. !+1-681-512-2222! AB-47209," & @CRLF & _
"<Sophia Loren> +1-421-674-8974 Bern TP-46017" & @CRLF & _
" <Peter O'Brien> High Street +1-908-512-2222; CC-47209" & @CRLF & _
"<Anastasia> +48-421-674-8974 Via Quirinal Roma" & @CRLF & _
" <P Salinger> Main Street, +1-098-512-2222, Denver" & @CRLF & _
"<C Powel> *+19-421-674-8974 Chateau des Fosses Strasbourg F-68000" & @CRLF & _
" <Bernard Deltheil> +1-498-512-2222; Mount Av. Eldorado" & @CRLF & _
"+1-099-500-8000 <Peter Crush> Labrador Bd." & @CRLF & _
" +1-931-512-4855 <William Saurin> Bison Street CQ-23071" & @CRLF & _
"<P Salinge> Main Street, +1-098-512-2222, Denve" & @CRLF & _
"<P Salinge> Main Street, +1-098-512-2222, Denve" & @CRLF & _
"/+5-541-754-3010 156 Alphandria_Street. <Jr Part>" & @CRLF & _
" 1333, Green, Road <F Fulgur> NW-46423 ;+6-541-914-3010!" & @CRLF & _
"+5-541-984-3012 <Peter Reeves> /PO Box 5300; Albertville, SC-28573" & @CRLF & _
" :+5-321-512-2222 <Paulo Divino> Boulder Alley ZQ-87209" & @CRLF & _
"+3-741-984-3090 <F Flanaghan> _Chicago Av." & @CRLF & _
" :+3-921-333-2222 <Roland Scorsini> Bellevue_Street DA-67209" & @CRLF & _
"+8-111-544-8973 <Laurence Pantow> SA" & @CRLF & _
" +8-921-512-2222 <Raymond Stevenson> Joly Street EE-67209" & @CRLF & _
"<John Freeland> Mantow ?+2-121-544-8974 " & @CRLF & _
" <Robert Mitch> Eleonore Street QB-87209 +2-481-512-2222?" & @CRLF & _
"<Arthur Paternos> San Antonio $+7-121-504-8974 TT-45121" & @CRLF & _
" <Ray Charles> Stevenson Pk. !+7-681-512-2222! CB-47209," & @CRLF & _
"<JP Gorce> +9-421-674-8974 New-Bern TP-16017" & @CRLF & _
" <P McDon> Revolution Street +2-908-512-2222; PP-47209" & @CRLF & _
"<Elizabeth Corber> +8-421-674-8974 Via Papa Roma" & @CRLF & _
" <C Saborn> Main Street, +15-098-512-2222, Boulder" & @CRLF & _
"<Colin Marshall> *+9-421-674-8974 Edinburgh UK" & @CRLF & _
" <Bernard Povit> +3-498-512-2222; Hill Av. Cameron" & @CRLF & _
"+12-099-500-8000 <Pete Highman> Ontario Bd." & @CRLF & _
" +8-931-512-4855 <W Mount> Oxford Street CQ-23071" & @CRLF & _
"<Donald Drinkaw> Moon Street, +3-098-512-2222, Peterville"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")