#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(NASDAQ|NYSE|DOW)\.{1}[A-Z]+$"
Local $sString = "hola" & @CRLF & _
"NASDAQ.MMM" & @CRLF & _
"NASDAQ.AAPL" & @CRLF & _
"NASDAQ.2" & @CRLF & _
"NYSE.MMM" & @CRLF & _
"DOW.MMM"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")