$re = '/^(?:https?:\/\/)(?:((?!(?:tampan|klantentool)).*)\.)?datacon.nl(?:$|\/)/m';
$str = 'https://www.datacon.nl/
https://tampan.datacon.nl/
https://klantentool.datacon.nl/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);