import Foundation
let pattern = #"((([12]{1}\d\d)|(1-9]\d)|([1-9]))[\.]){3}(([12]{1}\d\d)|([1-9]\d)|([1-9]))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1.2.3.4"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}