re = /[vn]\.?\s*(C(hr?)?\.?|(Z(tr?)?\.?))/mi
str = 'vc
vc.
vch
vchr
v.C
v.C.
v. Ch
v. Ch.
v. Chr.↵
vz
vz.
vzt
vztr
v.Z
v.Z.
v. Zt
v. Zt.
v. Ztr.↵
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end