$re = '/https:\/\/www\.bugaboo\.com\/(sv|es|de|gb|nl|us|fr|se|it|at|be|ie|fi|cz|dk|sk|pt|hr|hu|lu|si)-.{2}\/(strollers|carritos|kinderwagen|pushchairs|poussettes|passeggini|barnvagn).*\.html/m';
$str = 'https://www.bugaboo.com/es-es/carritos/bugaboo-fox-2/bugaboo-fox-2-seat-and-bassinet-stroller-grey-melange-nr-sun-canopy-black-fabrics-aluminium-base-PV002048.html
https://www.bugaboo.com/sv-se/barnvagn/bugaboo-fox-2/bugaboo-fox-2-seat-and-bassinet-stroller-grey-melange-nr-sun-canopy-black-fabrics-aluminium-base-PV002048.html
https://www.bugaboo.com/se-en/strollers/bugaboo-fox-2/bugaboo-fox-2-seat-and-bassinet-stroller-grey-melange-nr-sun-canopy-black-fabrics-aluminium-base-PV002048.html
https://www.bugaboo.com/fr-fr/poussettes/bugaboo-fox-2/bugaboo-fox-2-seat-and-bassinet-stroller-grey-melange-nr-sun-canopy-black-fabrics-aluminium-base-PV002048.html
https://www.bugaboo.com/fr-fr/poussettes/bugaboo-fox-2/poussette-naissance-et-2e-age-bugaboo-fox-2-CF001794.html
https://www.bugaboo.com/fr-fr/poussettes/bugaboo-ant/
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);