$re = '/^(0|\+34)[1-9]([0-9]{2}){4}/i';
$str = '+34931845909';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);