using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\,(.*?)\:";
string input = @"name:0001,code:0003,";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}