# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((?:[^;<>]+;)*)(?:[^;]*(?:<|>)[^;]*;)*([^;<>]+)(?:;[^;]*(?:<|>)[^;]*)*((?:;[^;<>]+)*)(?:;[^;]*(?:<|>)[^;]*)*((?:;[^;<>]+)*)(?:;[^;]*(?:<|>)[^;]*)*((?:;[^;<>]+)*)(?:;[^;]*(?:<|>)[^;]*)*((?:;[^;<>]+)*)$"
test_str = ("prov=b6a9a797-88de-95cf-705f-f04475ea4d8a; _ym_uid=1565792005592706499; _ym_uid=1565792005592706499; _ym_uid=1565792005592706499; _ym_uid=1565792005592706499; _ym_uid=1565792005592706499; _gid=GA1.2.19039273<28.1568202810; _ga=GA1.2.175<2530920.1564494>781; _ga=GA1.2.175<2530920.1564494>781; _ga=GA1.2.175<2530920.1564494>781; _ga=GA1.2.175<2530920.1564494>781; _ga=GA1.2.175<2530920.1564494>781; _ga=GA1.2.175<2530920.1564494>781; _ga=GA1.2.175<2530920.1564494>781; _ga=GA1.2.175<2530920.1564494>781; _ga=GA1.2.175<2530920.1564494>781; acct=t=YAiQ2RXtOBOG1Pf5UnKFxWZ%2bcINrjVde&s=%2btpIj7pF1GMoTVFuiDTS95VXolHih4l%2f; _ym_uid=1565792005592706499; _ym_uid=1565792005592706499; _ym_uid=1565792005592706499;_ym_uid=1565792005592706499;_ga=GA1.2.175<2530920.1564494>781;_ga=GA1.2.175<2530920.1564494>781;_ga=GA1.2.175<2530920.1564494>781;_ga=GA1.2.175<2530920.1564494>781;_ga=GA1.2.175<2530920.1564494>781;_ga=GA1.2.175<2530920.1564494>781; __gads=ID=fbdbf646c4f1b756:T=1564494781:S=ALNI_MaF9--jX-1UcW8INO5Pg9oENCXPJA; __qca=P0-1424341845-1564494781627; _ym_uid=1565792005592706499; _ym_d=1565792005; cc=e5a3d35ac7064d5caae23af2ce2caca0; superSecretTrackingCookie2=4efca328-421c-42e0-9426-96fbbb61cc51; _ym_uid=1565792005592706499; _ym_uid=1565792005592706499; _ym_uid=1565792005592706499;_gid=GA1.2.19039273<28.1568202810; acct=t=YAiQ2RXtOBOG1Pf5UnKFxWZ%2bcINrjVde&s=%2btpIj7pF1GMoTVFuiDTS95VXolHih4l%2f; _ym_uid=1565792005592706499; _ym_uid=1565792005592706499; _ym_uid=1565792005592706499; _ym_uid=1565792005592706499;_gid=GA1.2.19039273<28.1568202810;_gid=GA1.2.19039273<28.1568202810;_gid=GA1.2.19039273<28.1568202810;_gid=GA1.2.19039273<28.1568202810;_gid=GA1.2.19039273<28.1568202810;_gid=GA1.2.19039273<28.1568202810; acct=t=YAiQ2RXtOBOG1Pf5UnKFxWZ%2bcINrjVde&s=%2btpIj7pF1GMoTVFuiDTS95VXolHih4l%2f; _ym_uid=1565792005592706499; _ym_uid=1565792005592706499; _ym_uid=1565792005592706499; _ym_uid=1565792005592706499\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.