#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b\w{4}\b"
Local $sString = "Lorem colour ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, color quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. " & @CRLF & _
"single" & @CRLF & _
"" & @CRLF & _
"Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt coloursmollit anim id est laborum colors." & @CRLF & _
"words" & @CRLF & _
"" & @CRLF & _
"Lorem colour ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. " & @CRLF & _
"Ut enim ad minim veniam, color quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. " & @CRLF & _
"single" & @CRLF & _
"" & @CRLF & _
"Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt coloursmollit anim id est laborum colors." & @CRLF & _
"words"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")