$re = '/^1[3-9]你好\d{1,9}去$/m';
$str = 'abcdefg1234567890
你好
19你好83489去
14你好2去
19你好807974919去
23你好787361898去
18你好378972939去
12你好837834659去
18你好747593638去';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);