$re = '/^(?:\+98|0)(9\d{9})$/m';
$str = '09417207264';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);