# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=^|\W)([PpРр9]+[UuÙÚÛÜùúûü]+[TtТт7]+[AaÀÁÂÃÄÅĄàáâãäåąАаДд4@ª]+)(s?)(?=$|\W)"
test_str = ("putá el que lo lea putaaaááÁÁaaaa:puta🍕. hijo-de-puuta: Esto es una putada. pupupuputa puto\n"
"Pu7äs every where.PUTAPuTAaaa-PûTA. Había unos cuantos hijos de puutaááaaó puta\n"
"lalal putaaa7 que te put@sñññ que (puta) eres. puta puta puta\n"
"Reputados réputaçión -> la é y la ç son \\W\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.