const regex = /(\D+)(\d+)(\D)(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\D+)(\\d+)(\\D)(\\d+)', 'gm')
const str = `V230630C00200000
COIN230630C00020000
TSLA230818P00025000
SPXS230630C00019000
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}