# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([A-Z0-9\/\(\)]*)\s?[0-9]*\s[A-Z\']*\s\b(ROAD|LANE|STREET|AVENUE|PARADE|WAY|DRIVE|HIGHWAY|PLACE)\b"
test_str = ("407/82 HAY STREET \n"
"A314/1 DEMETER STREET \n"
"51/14 HASSALL STREET \n"
"(LOT1022) 60 LACERTA ROAD \n"
"LOT1149 KELLY STREET \n"
"(LOT1003) KELLY STREET \n"
"(LOT1010) 65 ORION ROAD \n"
"(LOT1109) 80 LACERTA ROAD \n"
"(LOT1013) 59 ORION ROAD \n"
"(LOT1017) 28 MULUMULUNG STREET\n"
"(LOT1021) 62 LACERTA ROAD \n"
"A106/5 ADONIS AVENUE \n"
"C122/5 ADONIS AVENUE \n"
"17 DONCASTER STREET \n"
"E108/3 ADONIS AVENUE \n"
"103/46 WALKER STREET \n"
"C118/5 ADONIS AVENUE \n"
"13 GOODISON PARADE \n"
"305/6 BAY STREET \n"
"A507/18 O'DEA AVENUE ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.