#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)E:\\Software\\Download\\?(?!.*?\\).*$"
Local $sString = "E:\Software\Download\MSEdgeDL\miui_BOMB_21.1.28_f15be071ad_11.0" & @CRLF & _
"E:\Software\Download\MSEdgeDL" & @CRLF & _
"E:\Software\Download\"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")