const regex = /^(((\+?64[3-9]|0[3-9])\d{7})|((\+?642\d{1}|02\d{1})\d{6,8})|(((\+?64800|0800)|(\+?64508|0508))\d{6,8}))$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(((\\+?64[3-9]|0[3-9])\\d{7})|((\\+?642\\d{1}|02\\d{1})\\d{6,8})|(((\\+?64800|0800)|(\\+?64508|0508))\\d{6,8}))$', 'g')
const str = `0273123121`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}