#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?!error).)*$"
Local $sString = "word1 word1 word1 word word3 wordesd sdfsdf error dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1" & @CRLF & _
"word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfswdf safsdfsdf word1" & @CRLF & _
"word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1" & @CRLF & _
"word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1" & @CRLF & _
"word1 word1 word1 word word3 wordsdr sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1" & @CRLF & _
"word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1" & @CRLF & _
"word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1" & @CRLF & _
"word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1" & @CRLF & _
"word1 word1 word1 word rword3 wordsd error rsdfsdf dsf sword1 words2 word2 word1 sdfsdf safsdfsdf word1" & @CRLF & _
"word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1" & @CRLF & _
"word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1" & @CRLF & _
"word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1" & @CRLF & _
"word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1" & @CRLF & _
"word1 word1 word1 word word3 wordsd rsdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1" & @CRLF & _
"word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1" & @CRLF & _
"word1 word1 word1 word wored3 wordsd error sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1" & @CRLF & _
"word1 word1 word1 word wordr3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1" & @CRLF & _
"word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1" & @CRLF & _
"word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 woerd1 sdfsdf safsdfsdf word1" & @CRLF & _
"word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")