re = /\A(?:(?:^(?P<type>feat|fix|ci|chore|docs|test|style|refactor|build|perf|revert)(?:\((?P<scope>[\w-]+)\))?(?P<breaking>!)?:\s(?P<subject>\b[\w#<> .\/\t\\-]{3,}(?:\b|\.))$)(?:(?:(?P<BLANK_LINE>\n^$\n)(?P<body>(?:^.{3,}(?:\b|\.)$\n?){1,3}))?(?P<BLANK_LINE2>\n^$\n)(?:(?P<breaking_change>^BREAKING\sCHANGE:\s[\s\w]+(?:\b|\.)$)\n)?(?:(?P<footer>^\w+:\s[\w#-]+(?:\b|\.))))?\n?|)\Z/m
str = 'feat(regular-expression_conventionalCommitsỦniçode)!: Subject-3302 úniçode samlpe
Validating everything for best conventionalCommits usage
thanks
Éverything is Ủniçode now
BREAKING CHANGE: breaking change description
Footer: footer'
# Print the match result
str.match(re) do |match|
puts match.to_s
end