re = /^(.*?)@(.*$)/m
str = 'hello
hello@gmail.com
hey@hotmail.com
hello@something.no'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end