$re = '/([\S]*)[\s]+([\S]*[\s]+[\S]*)[\s]+([0-9]{1,2})\%/i';
$str = 'RY4 Asian Flavor 10-15%
RY4 Double Flavor 5%-15%
Smooth Flavor 2 drops per 5 ml
Spearmint Flavor <5% Very Strong
Strawberries and Cream Flavor 10-12%
Strawberry Flavor 3%-15%
Strawberry Kiwi 20% 1/5
Strawberry Ripe 15%
Sweet Cream Flavor 5-10% 4/5 recommended for combining fake butter taste
Sweet Tart: 10% 5/5 Tastes more like Smarties
Sweetener 2%-6%
Tangerine Flavor (oil based) 1-5% 5/5
Tiramisu Flavor 2-5% VERY strong
Toasted Almond Flavor 15%';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);