re = /(.p=\d*\&utm_source.*)/
str = '?p=10886&utm_source=newsletter&utm_medium=email&utm_term=https%3A%2F%2Fajp.com.au%2F%3Fp%3D10886&utm_content&utm_campaign=AJP+Daily+-+7+April+2016'
# Print the match result
str.match(re) do |match|
puts match.to_s
end