re = /(^(([0-1]?\d{1,2})|(2[0-5]{2}))(\.(([0-1]?\d{1,2})|(2[0-5]{2}))){3}$)/
str = '194.115.1.4
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end