import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\+97[\\s]{0,1}[\\-]{0,1}[\\s]{0,1}1|0)50[\\s]{0,1}[\\-]{0,1}[\\s]{0,1}[1-9]{1}[0-9]{6}";
final String string = "Matches (mobile)\n"
+ "+97150 3827741 | 0503827741 | 050-3827741\n"
+ "Non-Matches \n"
+ "040 3827741 | 05 3827741 | 050_______spaces_______3827741\n\n"
+ "Matches (land)\n"
+ "04 3452488 | 04 -3452488 | 04 - 3452499\n"
+ "Non-Matches \n"
+ "01 -3452488 | 04 34524888 | 04 3452488\n\n"
+ "Other tests\n"
+ "+97150 3827741 | +97150 3827741";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}