const regex = /(?<ModelCode>\w{1})\((?<CountryCode>\w{3,4})\)\-(?<ModelNumber>\w{2})(\-(?<StackerType>\w{2}))? (?<InterfaceType>ID003\-\d{2})v(?<SoftwareVersion>\d{3}\-\d{2}) (?<SotfwareDate>\w+) (?<Crc>\w{4})/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<ModelCode>\\w{1})\\((?<CountryCode>\\w{3,4})\\)\\-(?<ModelNumber>\\w{2})(\\-(?<StackerType>\\w{2}))? (?<InterfaceType>ID003\\-\\d{2})v(?<SoftwareVersion>\\d{3}\\-\\d{2}) (?<SotfwareDate>\\w+) (?<Crc>\\w{4})', 'i')
const str = `P(EUR)-07 ID003-04V201-63 08JUN10 14C0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}