const regex = /(?:\s*|\r)+GO(\s*);*\s*(?:\r|\n)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\s*|\\r)+GO(\\s*);*\\s*(?:\\r|\\n)', 'gmi')
const str = `GO;
[11-02-2016 08:14] Rene Krone:
/* To prevent any potential data loss issues, you should review this script in detail before running it outside the context of the database designer.*/
BEGIN TRANSACTION
SET QUOTED_IDENTIFIER ON
SET ARITHABORT ON
SET NUMERIC_ROUNDABORT OFF
SET CONCAT_NULL_YIELDS_NULL ON
SET ANSI_NULLS ON
SET ANSI_PADDING ON
SET ANSI_WARNINGS ON
COMMIT
BEGIN TRANSACTION
Go ;
ALTER TABLE dbo.ResultCodes ADD
ShortDescription nvarchar(50) NULL,
EnglishDescription nvarchar(100) NULL
gO;
ALTER TABLE dbo.ResultCodes SET (LOCK_ESCALATION = TABLE) GO PRINT 'PLEASE GO ; '
GO
COMMIT
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}