$re = '/<\/?(?:\b(?!(?:div|tag)\b))([a-zA-Z0-9]+).*?>/';
$str = '<div> <diva a> <a> <h9>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);