re = /(https?):\/\/(\[[\:[:xdigit:]]+\]|[-\.[:alnum:]]+)(:(\d+))?(\/.*)/m
str = 'http://[e::]:8081/mStoreRoot/fms/v1/tenant/mavenir/MoH/files/MoH/EN/musiconhold/calls/1.mp3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end