using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!=\ )(?<![=&|%])(\+|-)(?!\1|[ =])";
string input = @"a - b + c
a-b+c
a-=2
a=-2
a&-b
a|-2
a%-b
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}