// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^((1[6789]|[2-9][0-9])[0-9]{2}-(0[13578]|1[02])-(0[1-9]|[12][0-9]|3[01]))(\s)(([0-1][0-9]|2[0-3]):([0-5][0-9]):([0-5][0-9])|(24:00:00))?$|^((1[6789]|[2-9][0-9])[0-9]{2}-(0[469]|11)-(0[1-9]|[12][0-9]|30))(\s)(([0-1][0-9]|2[0-3]):([0-5][0-9]):([0-5][0-9])|(24:00:00))?$|^(((16|[248][048]|[3579][26])00)|(1[6789]|[2-9][0-9])(0[48]|[13579][26]|[2468][048]))-02-(0[1-9]|1[0-9]|2[0-9])(\s)(([0-1][0-9]|2[0-3]):([0-5][0-9]):([0-5][0-9])|(24:00:00))?$|^(1[6789]|[2-9][0-9])[0-9]{2}-02-(0[1-9]|1[0-9]|2[0-8])(\s)(([0-1][0-9]|2[0-3]):([0-5][0-9]):([0-5][0-9])|(24:00:00))?$").unwrap();
let string = "2000-02-29 12:12:10";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}