import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https?\\:\\/\\/)?(www\\.)?([a-z0-9]+\\.)+([a-z]{2,})(\\/[a-zA-Z0-9\\-_]+)+(\\.)+(jpg|png|bmp|jpeg){1}";
final String string = "https://i.imgur.com/PYiHYPX.jpg";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}