$re = '/[0-9] [a-b]/m';
$str = '1 a
2 a
3 a
4 a
5 a
8 a
9 b';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);