#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\b([A-Z]{2})[^A-Z0-9]*?([0-9]{1,2})[^A-Z0-9]*?([A-Z]{0,3})[^A-Z0-9]*?([0-9]{4})\b"
Local $sString = "MP13QH3998" & @CRLF & _
"MP-13-QH-3998" & @CRLF & _
"MP 13 QH 3998" & @CRLF & _
"RJ 03QH3918" & @CRLF & _
"RJ 03QH3918" & @CRLF & _
"MP,,,03-QH3998" & @CRLF & _
"MP03QH3998" & @CRLF & _
"" & @CRLF & _
"invalid inputs:" & @CRLF & _
"MP,,01,03-QH3998" & @CRLF & _
"MP0203QH3998" & @CRLF & _
"MP03QJJH3998" & @CRLF & _
"MP03QH399998"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")