#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?usimUJ)^(?:[\+-]?\d{4}(?!\d{2}\b))(?:(-?)(?:(?:0[1-9]|1[0-2])(?:\1(?:[12]\d|0[1-9]|3[01]))?|W(?:[0-4]\d|5[0-2])(?:-?[1-7])?|(?:00[1-9]|0[1-9]\d|[12]\d{2}|3(?:[0-5]\d|6[1-6])))(?:[T\s](?:(?:(?:[01]\d|2[0-3])(?:(:?)[0-5]\d)?|24\:?00)(?:[\.,]\d+(?!:))?)?(?:\2[0-5]\d(?:[\.,]\d+)?)?(?:[zZ]|(?:[\+-])(?:[01]\d|2[0-3]):?(?:[0-5]\d)?)?)?)?$"
Local $sString = "2021" & @CRLF & _
"2021-10" & @CRLF & _
"" & @CRLF & _
"2021-00" & @CRLF & _
"2021-13" & @CRLF & _
"2021-10-24" & @CRLF & _
"2021-10-00" & @CRLF & _
"2021-10-32" & @CRLF & _
"2021-10-24T10" & @CRLF & _
"2021-10-24T48" & @CRLF & _
"2021-10-24T10:30" & @CRLF & _
"2021-10-24T10:95" & @CRLF & _
"2021-10-24T10:30:47" & @CRLF & _
"2021-10-24T10:30:78" & @CRLF & _
"2021-10-24T10:30:47.5" & @CRLF & _
"2021-10-24T10:30:47.333" & @CRLF & _
"2021-10-24T10:30:47.333333" & @CRLF & _
"2021-10-24T10:30:47Z" & @CRLF & _
"2021-10-24T10:30:78Z" & @CRLF & _
"2021-10-24T10:30:47.5Z" & @CRLF & _
"2021-10-24T10:30:47.333Z" & @CRLF & _
"2021-10-24T10:30:47.333333Z" & @CRLF & _
"2021-10-24T10:30:47-03:00" & @CRLF & _
"2021-10-24T10:30:78-03:00" & @CRLF & _
"2021-10-24T10:30:47.5-03:00" & @CRLF & _
"2021-10-24T10:30:47.333-03:00" & @CRLF & _
"2021-10-24T10:30:47.333333-03:00" & @CRLF & _
"Nate☬158⚈̥̥̥̥̥̀ᴗ✯"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")