$re = '/^(([+]\91[\s]?)?)\d{10}$/';
$str = '+917992289661';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);