use strict;
my $str = 'AKTURA FV000821 :JAAC*fibf:
DATA WYSTAWIENIA : 2020.06.08 ZLECENIE: 01
MIEJSCE WYSTAWIENIA : TORUŃ
DATA DOSTAWY TOWARU : 2020.06.08 UWAGI : zam. T561552 Z1
SPRZEDAWCA: "MEGA-TOOLS" S.C.
Marek Śpiewak,Mirosław Śpiewak ul.Osikowa 34 87-100 Toruń NIP 9562093313
ING Bank Śląski S.A. O/Toruń
49 1050 1979 1000 0022 7285 0849
NABYWCA: Pojazdy Szynowe PESA Bydgoszcz Spółka Akcyjna ul.Zygmunta Augusta 11 85-082 Bydgoszcz
NIP 554-031-17-75
[07-668]
Lp Opis towaru/uslugi Ilość jm. Cena Wartosc VAT
-----------------------------------------------------------------------------------------------
1 INNE-ELEK-9512 11. szt. 66,00 726,00 23.0% Lampa warsztatowa 30LED z ładowarką
---------------------------------------------------------------------------------------------- 726,00
Rozliczenie VAT Netto Podatek Brutto ----------------------------------------------------wg stawki 23.0% : 726,00 166,98 892,98 -----------------------------------------------------
RAZEM : 726,00 166,98 892,98
DO ZAPŁATY: 892,98 PLN
SŁOWNIE : osiemset dziewiecdziesiat dwa zl dziewiecdziesiat osiem gr
ZAPLACONO GOTOWKA : 0,00 PLN
POZOSTAŁO DO ZAPŁATY : 892,98 PLN
PŁATNE : PRZELEW DO 2020.08.07
NA KONTO : 49 1050 1979 1000 0022 7285 0849
Za niezapłacone należności w terminie, będą naliczone odsetki w wysokości ustawowej.
Dokument wystawiony i dostarczony nabywcy w formie elektronicznej.
Wystawca dokumentu FV000821 : MIROSŁAW ŚPIEWAK
';
my $regex = qr/(?i)(?<Lp>\d{1,2}(?![\s\S]*?(Lp\.|Ilość|jm\.)))\s*(?<NazwaProduktu1>([\S ]*?[\n\r]*){1,3})[\s\a]*(?<Ilosc>\d*)[.]?\s*(?<jm>[a-z]{3})[.]?[\s\a]*[\d\,\% \.]*(?<NazwaProduktu2>([a-ż\d ]*[\n\r]*){1,3})[\s\a]*/mup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}