$re = '/^\d{2}(\/|-)\d{2}(\/|-)(\d{2}|\d{4})$/m';
$str = '20-05-1989';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);