$re = '/(?<true_client_ip>[a-f0-9:.]+), [a-f0-9:.]+$/m';
$str = '1.1.1.1, 2.2.2.2
1.1.1.1, 2.2.2.2, 3.3.3.3
2001:db8:85a3:8d3:1319:8a2e:370:7348, 2001:db8:85a3:8d3:1319:8a2e:370:7348
2001:db8:85a3:8d3:1319:8a2e:370:7348, 2001:db8:85a3:8d3:1319:8a2e:370:7348, 2001:db8:85a3:8d3:1319:8a2e:370:7348
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);